3.1 ubuntu install issue

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

3.1 ubuntu install issue

Roy Walter-2
Server running openjdk-7-jre-headless.

Install runs fine until very end when get this error:

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/exist/start/Main : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)


Also, one minor installer point. The default install location suggested by the installer is the location of the distribution jar. Previous versions suggested /usr/local/eXist-db-[version], which was much better!


Thanks,
Roy





------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 3.1 ubuntu install issue

Pierrick Brihaye
Hi,

Le 09/03/2017 à 12:53, Roy Walter a écrit :

> Server running openjdk-7-jre-headless.

> Exception in thread "main" java.lang.UnsupportedClassVersionError:
> org/exist/start/Main : Unsupported major.minor version 52.0

eXist need Java 8...

Maybe the install software should warn about it...

> Also, one minor installer point. The default install location suggested
> by the installer is the location of the distribution jar. Previous
> versions suggested /usr/local/eXist-db-[version], which was much better!

Indeed

Cheers,

p.b.


------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Loading...