Admin password does not work

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Admin password does not work

Montechristos Monty

Hi, after (multiple) clean installs, where I am sure I entered the correct password for admin, I am unable to log in even to do the basic tasks. It gives me incorrect username/password for 'admin'

Can you please help?

I am using:

Windows 10

Java version 1.8.0_121

eXist-db-setup-2.2.jar


Thanks in advance


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: Admin password does not work

Joe Wicentowski
Hi Montechristos,

Welcome to exist-open.  Could you please confirm that supplying a
blank password fails?  And if not, where are you doing these logins -
java admin client, exide, command line, etc.?

Joe

On Thu, Feb 2, 2017 at 8:57 AM, Montechristos Monty
<[hidden email]> wrote:

> Hi, after (multiple) clean installs, where I am sure I entered the correct
> password for admin, I am unable to log in even to do the basic tasks. It
> gives me incorrect username/password for 'admin'
>
> Can you please help?
>
> I am using:
>
> Windows 10
>
> Java version 1.8.0_121
>
> eXist-db-setup-2.2.jar
>
>
> Thanks in advance
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> Exist-open mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/exist-open
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: Admin password does not work

Joe Wicentowski
Hi Montechristos,

(Copying the whole list so everyone can benefit from our discussion.)

Great, thanks for confirming that.  See Wolfgang's instructions for
recovering in a "lost password" scenario like yours:

  http://markmail.org/message/7odprn2qjdo6z5ol

For detailed instructions on backup/restore, see this article from the
eXist-db documentation:

  http://exist-db.org/exist/apps/doc/backup.xml

The exist-open archives are a great source of information.  I find
exist-open.markmail.org quite convenient for this.

Good luck,
Joe

On Thu, Feb 2, 2017 at 10:20 AM, Montechristos Monty
<[hidden email]> wrote:

> Hi Joe and thanks for the prompt reply.
>
> Yes, I confirm that blank password also doesn't work.
> I have tried on the web interface (upper left login panel), the user
> management screen, as well as the Java admin client. None of these work
> neither with the password I have during installation nor blank
>
>
>
>
>
> On Feb 2, 2017 4:12 PM, "Joe Wicentowski" <[hidden email]> wrote:
>
> Hi Montechristos,
>
> Welcome to exist-open.  Could you please confirm that supplying a
> blank password fails?  And if not, where are you doing these logins -
> java admin client, exide, command line, etc.?
>
> Joe
>
> On Thu, Feb 2, 2017 at 8:57 AM, Montechristos Monty
> <[hidden email]> wrote:
>> Hi, after (multiple) clean installs, where I am sure I entered the correct
>> password for admin, I am unable to log in even to do the basic tasks. It
>> gives me incorrect username/password for 'admin'
>>
>> Can you please help?
>>
>> I am using:
>>
>> Windows 10
>>
>> Java version 1.8.0_121
>>
>> eXist-db-setup-2.2.jar
>>
>>
>> Thanks in advance
>>
>>
>>
>> ------------------------------------------------------------------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
>> _______________________________________________
>> Exist-open mailing list
>> [hidden email]
>> https:/the sts.sourceforge.net/lists/listinfo/exist-open
>>
>
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: Admin password does not work

Montechristos Monty
Hi Joe,

I managed to do an export and deleted the admin.xml as requested.
Then tried to restart exist-db to restore, but it was no longer starting....
Documentation on restore is not very good...

Anyway, I gave up and did a complete re-install without creating a password when requested.
This seemed to work.

Now I can move on to my evaluation of the solution :-)


Many thanks

PS: Some suggestions: for novice users that need to evaluate its capabilities, they should not get stuck in such issues.
Documentation needs to be improved also

On Thu, Feb 2, 2017 at 6:08 PM, Joe Wicentowski <[hidden email]> wrote:
Hi Montechristos,

(Copying the whole list so everyone can benefit from our discussion.)

Great, thanks for confirming that.  See Wolfgang's instructions for
recovering in a "lost password" scenario like yours:

  http://markmail.org/message/7odprn2qjdo6z5ol

For detailed instructions on backup/restore, see this article from the
eXist-db documentation:

  http://exist-db.org/exist/apps/doc/backup.xml

The exist-open archives are a great source of information.  I find
exist-open.markmail.org quite convenient for this.

Good luck,
Joe

On Thu, Feb 2, 2017 at 10:20 AM, Montechristos Monty
<[hidden email]> wrote:
> Hi Joe and thanks for the prompt reply.
>
> Yes, I confirm that blank password also doesn't work.
> I have tried on the web interface (upper left login panel), the user
> management screen, as well as the Java admin client. None of these work
> neither with the password I have during installation nor blank
>
>
>
>
>
> On Feb 2, 2017 4:12 PM, "Joe Wicentowski" <[hidden email]> wrote:
>
> Hi Montechristos,
>
> Welcome to exist-open.  Could you please confirm that supplying a
> blank password fails?  And if not, where are you doing these logins -
> java admin client, exide, command line, etc.?
>
> Joe
>
> On Thu, Feb 2, 2017 at 8:57 AM, Montechristos Monty
> <[hidden email]> wrote:
>> Hi, after (multiple) clean installs, where I am sure I entered the correct
>> password for admin, I am unable to log in even to do the basic tasks. It
>> gives me incorrect username/password for 'admin'
>>
>> Can you please help?
>>
>> I am using:
>>
>> Windows 10
>>
>> Java version 1.8.0_121
>>
>> eXist-db-setup-2.2.jar
>>
>>
>> Thanks in advance
>>
>>
>>
>> ------------------------------------------------------------------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
>> _______________________________________________
>> Exist-open mailing list
>> [hidden email]
>> https:/the sts.sourceforge.net/lists/listinfo/exist-open
>>
>
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: Admin password does not work

Joe Wicentowski
Hi Montechristos,

I am unsure what could've led to the problem you experienced, but if
you're evaluating eXist I'd suggest using the current release
candidate (eXist 3.0-RC1 available via exist-db.org under Downloads)
or, for the most current version that is shortly to be released
(according to my understanding - I'm just another user), download the
latest nightly build from
http://static.adamretter.org.uk/exist-nightly/.  The 3.0 branch has
many, many fixes and improvements over 2.2, particularly for Windows
users.  For your own sanity's sake, I'd recommend going with the
latest nightly.

Surely documentation could be improved.  If there are specific
portions of the documentation that you found lacking or incomplete,
we'd appreciate your feedback.  But "not very good" is also not very
specific.

Joe

On Thu, Feb 2, 2017 at 12:10 PM, Montechristos Monty
<[hidden email]> wrote:

> Hi Joe,
>
> I managed to do an export and deleted the admin.xml as requested.
> Then tried to restart exist-db to restore, but it was no longer starting....
> Documentation on restore is not very good...
>
> Anyway, I gave up and did a complete re-install without creating a password
> when requested.
> This seemed to work.
>
> Now I can move on to my evaluation of the solution :-)
>
>
> Many thanks
>
> PS: Some suggestions: for novice users that need to evaluate its
> capabilities, they should not get stuck in such issues.
> Documentation needs to be improved also
>
> On Thu, Feb 2, 2017 at 6:08 PM, Joe Wicentowski <[hidden email]> wrote:
>>
>> Hi Montechristos,
>>
>> (Copying the whole list so everyone can benefit from our discussion.)
>>
>> Great, thanks for confirming that.  See Wolfgang's instructions for
>> recovering in a "lost password" scenario like yours:
>>
>>   http://markmail.org/message/7odprn2qjdo6z5ol
>>
>> For detailed instructions on backup/restore, see this article from the
>> eXist-db documentation:
>>
>>   http://exist-db.org/exist/apps/doc/backup.xml
>>
>> The exist-open archives are a great source of information.  I find
>> exist-open.markmail.org quite convenient for this.
>>
>> Good luck,
>> Joe
>>
>> On Thu, Feb 2, 2017 at 10:20 AM, Montechristos Monty
>> <[hidden email]> wrote:
>> > Hi Joe and thanks for the prompt reply.
>> >
>> > Yes, I confirm that blank password also doesn't work.
>> > I have tried on the web interface (upper left login panel), the user
>> > management screen, as well as the Java admin client. None of these work
>> > neither with the password I have during installation nor blank
>> >
>> >
>> >
>> >
>> >
>> > On Feb 2, 2017 4:12 PM, "Joe Wicentowski" <[hidden email]> wrote:
>> >
>> > Hi Montechristos,
>> >
>> > Welcome to exist-open.  Could you please confirm that supplying a
>> > blank password fails?  And if not, where are you doing these logins -
>> > java admin client, exide, command line, etc.?
>> >
>> > Joe
>> >
>> > On Thu, Feb 2, 2017 at 8:57 AM, Montechristos Monty
>> > <[hidden email]> wrote:
>> >> Hi, after (multiple) clean installs, where I am sure I entered the
>> >> correct
>> >> password for admin, I am unable to log in even to do the basic tasks.
>> >> It
>> >> gives me incorrect username/password for 'admin'
>> >>
>> >> Can you please help?
>> >>
>> >> I am using:
>> >>
>> >> Windows 10
>> >>
>> >> Java version 1.8.0_121
>> >>
>> >> eXist-db-setup-2.2.jar
>> >>
>> >>
>> >> Thanks in advance
>> >>
>> >>
>> >>
>> >>
>> >> ------------------------------------------------------------------------------
>> >> Check out the vibrant tech community on one of the world's most
>> >> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
>> >> _______________________________________________
>> >> Exist-open mailing list
>> >> [hidden email]
>> >> https:/the sts.sourceforge.net/lists/listinfo/exist-open
>> >>
>> >
>> >
>
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: Admin password does not work

Montechristos Monty
Hi Joe,

Thanks, I will try with the latest nightly release.

Ok, point taken! :-)
Here is the part of the documentation that I think could be improved:
Restoring the Database
 - Important Note about the Restore Process
 - Restore Using the Java Client
 To restore the database files from a backup, you can again use either the Admin Client, or the backup command line utility.
 /* the backup command-line utility is not really a java client. Also, where can this be found? */
 If you are using the Admin Client, do the following...
 /* After doing an export using the GUI: java -jar start.jar org.exist.backup.ExportGUI my eXist would no longer start. It gave an error and the dashboard did not start
 Also, since there was an ExportGUI command, I would have expected to find the ImportGUI command
 The alternative is to use the command-line, but it requires admin credentials which is exactly the reason why I did the export/restore */
 
 I think the BUG that should be looked at is that, in windows, if you enter a password during installation, the same password does not work afterwards.
 
 Hope it is a little clearer.

PS: please note that I am a newbie to eXist-DB and I am very interested in its capabilities.
 


On Thu, Feb 2, 2017 at 6:17 PM, Joe Wicentowski <[hidden email]> wrote:
Hi Montechristos,

I am unsure what could've led to the problem you experienced, but if
you're evaluating eXist I'd suggest using the current release
candidate (eXist 3.0-RC1 available via exist-db.org under Downloads)
or, for the most current version that is shortly to be released
(according to my understanding - I'm just another user), download the
latest nightly build from
http://static.adamretter.org.uk/exist-nightly/.  The 3.0 branch has
many, many fixes and improvements over 2.2, particularly for Windows
users.  For your own sanity's sake, I'd recommend going with the
latest nightly.

Surely documentation could be improved.  If there are specific
portions of the documentation that you found lacking or incomplete,
we'd appreciate your feedback.  But "not very good" is also not very
specific.

Joe

On Thu, Feb 2, 2017 at 12:10 PM, Montechristos Monty
<[hidden email]> wrote:
> Hi Joe,
>
> I managed to do an export and deleted the admin.xml as requested.
> Then tried to restart exist-db to restore, but it was no longer starting....
> Documentation on restore is not very good...
>
> Anyway, I gave up and did a complete re-install without creating a password
> when requested.
> This seemed to work.
>
> Now I can move on to my evaluation of the solution :-)
>
>
> Many thanks
>
> PS: Some suggestions: for novice users that need to evaluate its
> capabilities, they should not get stuck in such issues.
> Documentation needs to be improved also
>
> On Thu, Feb 2, 2017 at 6:08 PM, Joe Wicentowski <[hidden email]> wrote:
>>
>> Hi Montechristos,
>>
>> (Copying the whole list so everyone can benefit from our discussion.)
>>
>> Great, thanks for confirming that.  See Wolfgang's instructions for
>> recovering in a "lost password" scenario like yours:
>>
>>   http://markmail.org/message/7odprn2qjdo6z5ol
>>
>> For detailed instructions on backup/restore, see this article from the
>> eXist-db documentation:
>>
>>   http://exist-db.org/exist/apps/doc/backup.xml
>>
>> The exist-open archives are a great source of information.  I find
>> exist-open.markmail.org quite convenient for this.
>>
>> Good luck,
>> Joe
>>
>> On Thu, Feb 2, 2017 at 10:20 AM, Montechristos Monty
>> <[hidden email]> wrote:
>> > Hi Joe and thanks for the prompt reply.
>> >
>> > Yes, I confirm that blank password also doesn't work.
>> > I have tried on the web interface (upper left login panel), the user
>> > management screen, as well as the Java admin client. None of these work
>> > neither with the password I have during installation nor blank
>> >
>> >
>> >
>> >
>> >
>> > On Feb 2, 2017 4:12 PM, "Joe Wicentowski" <[hidden email]> wrote:
>> >
>> > Hi Montechristos,
>> >
>> > Welcome to exist-open.  Could you please confirm that supplying a
>> > blank password fails?  And if not, where are you doing these logins -
>> > java admin client, exide, command line, etc.?
>> >
>> > Joe
>> >
>> > On Thu, Feb 2, 2017 at 8:57 AM, Montechristos Monty
>> > <[hidden email]> wrote:
>> >> Hi, after (multiple) clean installs, where I am sure I entered the
>> >> correct
>> >> password for admin, I am unable to log in even to do the basic tasks.
>> >> It
>> >> gives me incorrect username/password for 'admin'
>> >>
>> >> Can you please help?
>> >>
>> >> I am using:
>> >>
>> >> Windows 10
>> >>
>> >> Java version 1.8.0_121
>> >>
>> >> eXist-db-setup-2.2.jar
>> >>
>> >>
>> >> Thanks in advance
>> >>
>> >>
>> >>
>> >>
>> >> ------------------------------------------------------------------------------
>> >> Check out the vibrant tech community on one of the world's most
>> >> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
>> >> _______________________________________________
>> >> Exist-open mailing list
>> >> [hidden email]
>> >> https:/the sts.sourceforge.net/lists/listinfo/exist-open
>> >>
>> >
>> >
>
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open