Cocoon 2.1.8-dev & Lastest exist snapshot.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Cocoon 2.1.8-dev & Lastest exist snapshot.

Aurélien DEHAY
Hello all.

I'm trying to install eXist on a running 2.1.8-dev Cocoon. I'm following
the indications in http://wiki.exist-db.org/space/CocoonInstall but I've
got the followingf error at startup:

java.lang.SecurityException: class
"org.xmldb.api.base.CompiledExpression"'s signer information does not
match signer information of other classes in the same package

Maybe I'm doing something wrong? Did anybody success to install such a
configuration?

Rgds.
--
Aurélien


-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: Cocoon 2.1.8-dev & Lastest exist snapshot.

Jonas Lundberg
Yes,
that is described here:
http://www.ida.liu.se/~jonlu/shapeshifter/existblock.htm

IF you get an exception involving
org.xmldb.api.base.CompiledExpression then get rid of all java files
in the webapp/WEB-INF/lib library that has anything with xmldb in the
file name AND which also are NOT part of the eXist package. Test your
way forward by renaming the extension of the files. Then you can
rename them back if you make a mistake.

Please let me know if that does not work for 2.1.8, I have only tested
it with 2.1.7

Hans

On 10/20/05, Aurélien DEHAY <[hidden email]> wrote:

> Hello all.
>
> I'm trying to install eXist on a running 2.1.8-dev Cocoon. I'm following
> the indications in http://wiki.exist-db.org/space/CocoonInstall but I've
> got the followingf error at startup:
>
> java.lang.SecurityException: class
> "org.xmldb.api.base.CompiledExpression"'s signer information does not
> match signer information of other classes in the same package
>
> Maybe I'm doing something wrong? Did anybody success to install such a
> configuration?
>
> Rgds.
> --
> Aurélien
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by:
> Power Architecture Resource Center: Free content, downloads, discussions,
> and more. http://solutions.newsforge.com/ibmarch.tmpl
> _______________________________________________
> Exist-open mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/exist-open
>


-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: Cocoon 2.1.8-dev & Lastest exist snapshot.

Aurélien DEHAY
Hi

Jonas Lundberg a écrit :
> Yes,
> that is described here:
> http://www.ida.liu.se/~jonlu/shapeshifter/existblock.htm

It's a old version, I've used the latest eXist snapshot

>
> IF you get an exception involving
> org.xmldb.api.base.CompiledExpression then get rid of all java files
> in the webapp/WEB-INF/lib library that has anything with xmldb in the
> file name AND which also are NOT part of the eXist package. Test your
> way forward by renaming the extension of the files. Then you can
> rename them back if you make a mistake.
>
> Please let me know if that does not work for 2.1.8, I have only tested
> it with 2.1.7

I've followed the instruction from the exist wiki. It's working, I had
just forgot to delete some jar files...

Thx.

>
> Hans
>
> On 10/20/05, Aurélien DEHAY <[hidden email]> wrote:
>
>>Hello all.
>>
>>I'm trying to install eXist on a running 2.1.8-dev Cocoon. I'm following
>>the indications in http://wiki.exist-db.org/space/CocoonInstall but I've
>>got the followingf error at startup:
>>
>>java.lang.SecurityException: class
>>"org.xmldb.api.base.CompiledExpression"'s signer information does not
>>match signer information of other classes in the same package
>>
>>Maybe I'm doing something wrong? Did anybody success to install such a
>>configuration?
>>
>>Rgds.
>>--
>>Aurélien
>>
>>
>>-------------------------------------------------------
>>This SF.Net email is sponsored by:
>>Power Architecture Resource Center: Free content, downloads, discussions,
>>and more. http://solutions.newsforge.com/ibmarch.tmpl
>>_______________________________________________
>>Exist-open mailing list
>>[hidden email]
>>https://lists.sourceforge.net/lists/listinfo/exist-open
>>
>
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by:
> Power Architecture Resource Center: Free content, downloads, discussions,
> and more. http://solutions.newsforge.com/ibmarch.tmpl
> _______________________________________________
> Exist-open mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/exist-open
>



-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open