Exist 3.2 deployment on jetty 9.4.5

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Exist 3.2 deployment on jetty 9.4.5

Benjamin W. Bohl
Hi all,

I have a problem deploying the published exist-3.2.0.war in Jetty 9.4.5.
When jetty scans for web apps I get the following error:

2017-05-09 09:03:33.184:WARN:oejw.WebAppContext:main: Failed startup of context o.e.j.w.WebAppContext@7a69b07{/exist,[file:///Library/Jetty/webapps/exist/, jar:file:///Library/Jetty/webapps/exist/WEB-INF/lib/betterform-exist-5.1-SNAPSHOT-20160615.jar!/META-INF/resources],UNAVAILABLE}{/exist}
java.lang.IllegalStateException: No LoginService for org.eclipse.jetty.security.authentication.FormAuthenticator@51acdf2e in org.eclipse.jetty.security.ConstraintSecurityHandler@6a55299e
        …

Any ideas what’s going wrong? Maybe I did forget to do some configuration? Or does eXist-db need a specific Jetty version?

Could this be connected to https://github.com/eXist-db/exist/issues/1352

Many thanks,
Benjamin


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: Exist 3.2 deployment on jetty 9.4.5

Adam Retter
Could you put the full stack trace somewhere for us please? Also any relevant log files.

On 9 May 2017 3:18 a.m., "Benjamin W. Bohl" <[hidden email]> wrote:
Hi all,

I have a problem deploying the published exist-3.2.0.war in Jetty 9.4.5.
When jetty scans for web apps I get the following error:

2017-05-09 09:03:33.184:WARN:oejw.WebAppContext:main: Failed startup of context o.e.j.w.WebAppContext@7a69b07{/exist,[file:///Library/Jetty/webapps/exist/, jar:file:///Library/Jetty/webapps/exist/WEB-INF/lib/betterform-exist-5.1-SNAPSHOT-20160615.jar!/META-INF/resources],UNAVAILABLE}{/exist}
java.lang.IllegalStateException: No LoginService for org.eclipse.jetty.security.authentication.FormAuthenticator@51acdf2e in org.eclipse.jetty.security.ConstraintSecurityHandler@6a55299e
        …

Any ideas what’s going wrong? Maybe I did forget to do some configuration? Or does eXist-db need a specific Jetty version?

Could this be connected to https://github.com/eXist-db/exist/issues/1352

Many thanks,
Benjamin


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open