Quantcast

Packages gone after restart in eXist 3.0 latest develop

classic Classic list List threaded Threaded
21 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Packages gone after restart in eXist 3.0 latest develop

wshager
Hi,

Since yesterday I've tried to get latest develop running on Ubuntu 14.04 (using sysv-init). For some reason installed packages are no longer available after a restart of the service. 

What I tried to fix this is: remove the entire expath repo directory and restart, and after that restore old apps from backup. This works fine until I restart again.

Does anyone experience the same bug? What should I do to prevent this?

Thanks,
Wouter

--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

Dannes Wessels-3
Hi,

On 24 Feb 2017, at 16:22 , W.S. Hager <[hidden email]> wrote:

Since yesterday I've tried to get latest develop running on Ubuntu 14.04 (using sysv-init). For some reason installed packages are no longer available after a restart of the service. 

What I tried to fix this is: remove the entire expath repo directory and restart, and after that restore old apps from backup. This works fine until I restart again.

Does anyone experience the same bug? What should I do to prevent this?

The questions that pop-up
  • Is the underlying hardware/filesystem stable?  
  • are all directories writable for the correct user? 
  • which java version do you use?
  • “restart of service’ = restart of unix service? is there a change of users involved (root vs different user)

regards

Dannes

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
Ah you're right, those are the questions to ask. Well, except of course about the file system stability. 

Java is latest Oracle 1.8, the service was installed for root.

Op 25 feb. 2017 3:25 p.m. schreef "Dannes Wessels" <[hidden email]>:
Hi,

On 24 Feb 2017, at 16:22 , W.S. Hager <[hidden email]> wrote:

Since yesterday I've tried to get latest develop running on Ubuntu 14.04 (using sysv-init). For some reason installed packages are no longer available after a restart of the service. 

What I tried to fix this is: remove the entire expath repo directory and restart, and after that restore old apps from backup. This works fine until I restart again.

Does anyone experience the same bug? What should I do to prevent this?

The questions that pop-up
  • Is the underlying hardware/filesystem stable?  
  • are all directories writable for the correct user? 
  • which java version do you use?
  • “restart of service’ = restart of unix service? is there a change of users involved (root vs different user)

regards

Dannes


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
Any response to this? The user that started the service was root, so it should have permissions no matter what.

2017-02-25 15:30 GMT+01:00 W.S. Hager <[hidden email]>:
Ah you're right, those are the questions to ask. Well, except of course about the file system stability. 

Java is latest Oracle 1.8, the service was installed for root.

Op 25 feb. 2017 3:25 p.m. schreef "Dannes Wessels" <[hidden email]>:

Hi,

On 24 Feb 2017, at 16:22 , W.S. Hager <[hidden email]> wrote:

Since yesterday I've tried to get latest develop running on Ubuntu 14.04 (using sysv-init). For some reason installed packages are no longer available after a restart of the service. 

What I tried to fix this is: remove the entire expath repo directory and restart, and after that restore old apps from backup. This works fine until I restart again.

Does anyone experience the same bug? What should I do to prevent this?

The questions that pop-up
  • Is the underlying hardware/filesystem stable?  
  • are all directories writable for the correct user? 
  • which java version do you use?
  • “restart of service’ = restart of unix service? is there a change of users involved (root vs different user)

regards

Dannes




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

Wolfgang Meier-2
> Any response to this? The user that started the service was root, so it should have permissions no matter what.

Could you check if the package repository in expathrepo is ok? Does it have a subdirectory expathrepo/.expath-pkg/ with two files: packages.txt and packages.xml? Could you check if both list all the packages you expect to see? If yes, does expathrepo.log say anything about packages being skipped during startup? This may happen if it finds that the expath-pkg.xml file is damaged/invalid XML.

Wolfgang
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
Sorry, I did not know there was a log for that. These lines may be relevant:


2017-02-24 17:32:41,030 [main] INFO  (ExistRepository.java [prepare]:80) - Using directory /usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo for expath package repository
2017-02-24 17:32:41,215 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://exist-db.org/apps/eXide is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,215 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://lagua.nl/pkg/rql is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,216 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://exist-db.org/apps/shared is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,216 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://exist-db.org/apps/benjamins is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,216 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://benjamins.com/apps/antiq is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,217 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://benjamins.com/apps/sites is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,217 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://exist-db.org/apps/dashboard is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,217 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://benjamins.com/apps/books is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,218 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://exist-db.org/apps/collectionbrowser is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,218 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://xqilla.sourceforge.net/pkg/xqjson is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,218 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://benjamins.com/apps/z.183 is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,219 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://benjamins.com/apps/bbr is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,219 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://benjamins.com/apps/royalties is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:32:41,219 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://benjamins.com/apps/shared/app is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.
2017-02-24 17:33:02,179 [main] INFO  (AutoDeploymentTrigger.java [execute]:67) - Scanning autodeploy directory. Found 3 app packages.
2017-02-24 17:33:02,230 [main] INFO  (Deployment.java [installAndDeploy]:191) - Application package http://exist-db.org/apps/dashboard already installed. Skipping.
2017-02-24 17:33:02,251 [main] INFO  (Deployment.java [installAndDeploy]:191) - Application package http://exist-db.org/apps/eXide already installed. Skipping.
2017-02-24 17:33:02,255 [main] INFO  (Deployment.java [installAndDeploy]:191) - Application package http://exist-db.org/apps/shared already installed. Skipping.


2017-02-28 14:08 GMT+01:00 Wolfgang Meier <[hidden email]>:
> Any response to this? The user that started the service was root, so it should have permissions no matter what.

Could you check if the package repository in expathrepo is ok? Does it have a subdirectory expathrepo/.expath-pkg/ with two files: packages.txt and packages.xml? Could you check if both list all the packages you expect to see? If yes, does expathrepo.log say anything about packages being skipped during startup? This may happen if it finds that the expath-pkg.xml file is damaged/invalid XML.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

Wolfgang Meier-2
> 2017-02-24 17:32:41,215 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://exist-db.org/apps/eXide is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.

Those messages can be ignored unless your package does include Java jar files to be loaded by the class loader.

Wolfgang
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
The package dirs seem to be as they should be, but when starting just now I see this:

INFO|27921/0|eXist-db|17-02-28 14:56:11|28 Feb 2017 14:56:11,107 [main] INFO  (JettyStart.java [run]:159) - Configuring eXist from /usr/local/eXist-db/conf.xml
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: Create a new repository with storage: File system storage in /usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.2/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.2/bbr'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/shared.benjamins.com-0.1/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/shared.benjamins.com-0.1/shared.benjamins.com'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/collectionbrowser-0.3/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/collectionbrowser-0.3/collectionbrowser'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/antiq-0.4/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/antiq-0.4/antiq'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.7/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.7/bbr'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/z.183-0.2/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/z.183-0.2/z.183'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/benjamins-0.4/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/benjamins-0.4/benjamins'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/eXide-2.1.3/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/eXide-2.1.3/eXide'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/royalties-0.1/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/royalties-0.1/royalties'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/dashboard-0.4.5/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/dashboard-0.4.5/dashboard'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/books.benjamins.com-0.1/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/books.benjamins.com-0.1/books.benjamins.com'
INFO|27921/0|eXist-db|17-02-28 14:56:11|Feb 28, 2017 2:56:11 PM org.expath.pkg.repo.tools.Logger info
INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/sites-0.2/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/sites-0.2/sites'


2017-02-28 14:16 GMT+01:00 Wolfgang Meier <[hidden email]>:
> 2017-02-24 17:32:41,215 [main] WARN  (ClasspathHelper.java [scanPackages]:90) - Package http://exist-db.org/apps/eXide is not compatible with this version of eXist. To avoid conflicts, Java libraries shipping with this package are not loaded.

Those messages can be ignored unless your package does include Java jar files to be loaded by the class loader.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

Wolfgang Meier-2
> INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.2/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.2/bbr‘

That’s just an info and should be ok. Could you go to the directory of one of the packages which are not loaded properly and check if the expath-pkg.xml file in there is valid XML? I occasionally found invalid or incompletely saved files.

Wolfgang
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
Well they're empty, that's the point. The expath-pkg.xml and repo.xml are the only files there.

2017-02-28 15:02 GMT+01:00 Wolfgang Meier <[hidden email]>:
> INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.2/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.2/bbr‘

That’s just an info and should be ok. Could you go to the directory of one of the packages which are not loaded properly and check if the expath-pkg.xml file in there is valid XML? I occasionally found invalid or incompletely saved files.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
The relevant xql files are in the backup, just to be complete.

2017-02-28 15:08 GMT+01:00 W.S. Hager <[hidden email]>:
Well they're empty, that's the point. The expath-pkg.xml and repo.xml are the only files there.

2017-02-28 15:02 GMT+01:00 Wolfgang Meier <[hidden email]>:
> INFO|27921/0|eXist-db|17-02-28 14:56:11|INFO: None of content dirs exist: '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.2/content' and '/usr/local/eXist-db/./webapp/WEB-INF/data/expathrepo/bbr-0.2/bbr‘

That’s just an info and should be ok. Could you go to the directory of one of the packages which are not loaded properly and check if the expath-pkg.xml file in there is valid XML? I occasionally found invalid or incompletely saved files.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

Wolfgang Meier-2
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
Well, there's no dashboard.

I'm trying to restore again, but I need to use a different port now. Unfortunately I can't seem to connect to another xmlrpc location (with -ouri param).

2017-02-28 15:13 GMT+01:00 Wolfgang Meier <[hidden email]>:
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
Ah wait the service runs on the machine IP, not localhost. I don't understand why that is though.

2017-02-28 15:19 GMT+01:00 W.S. Hager <[hidden email]>:
Well, there's no dashboard.

I'm trying to restore again, but I need to use a different port now. Unfortunately I can't seem to connect to another xmlrpc location (with -ouri param).

2017-02-28 15:13 GMT+01:00 Wolfgang Meier <[hidden email]>:
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
No dice of course: org.apache.xmlrpc.client.XmlRpcHttpTransportException: HTTP server returned unexpected status: Not Found


2017-02-28 15:20 GMT+01:00 W.S. Hager <[hidden email]>:
Ah wait the service runs on the machine IP, not localhost. I don't understand why that is though.

2017-02-28 15:19 GMT+01:00 W.S. Hager <[hidden email]>:
Well, there's no dashboard.

I'm trying to restore again, but I need to use a different port now. Unfortunately I can't seem to connect to another xmlrpc location (with -ouri param).

2017-02-28 15:13 GMT+01:00 Wolfgang Meier <[hidden email]>:
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
I can't seem to connect to xmlrpc in other ways, e.g. the java client.

2017-02-28 15:22 GMT+01:00 W.S. Hager <[hidden email]>:
No dice of course: org.apache.xmlrpc.client.XmlRpcHttpTransportException: HTTP server returned unexpected status: Not Found


2017-02-28 15:20 GMT+01:00 W.S. Hager <[hidden email]>:
Ah wait the service runs on the machine IP, not localhost. I don't understand why that is though.

2017-02-28 15:19 GMT+01:00 W.S. Hager <[hidden email]>:
Well, there's no dashboard.

I'm trying to restore again, but I need to use a different port now. Unfortunately I can't seem to connect to another xmlrpc location (with -ouri param).

2017-02-28 15:13 GMT+01:00 Wolfgang Meier <[hidden email]>:
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
Nor REST, somethings quite wrong I'm afraid.

2017-02-28 15:26 GMT+01:00 W.S. Hager <[hidden email]>:
I can't seem to connect to xmlrpc in other ways, e.g. the java client.

2017-02-28 15:22 GMT+01:00 W.S. Hager <[hidden email]>:
No dice of course: org.apache.xmlrpc.client.XmlRpcHttpTransportException: HTTP server returned unexpected status: Not Found


2017-02-28 15:20 GMT+01:00 W.S. Hager <[hidden email]>:
Ah wait the service runs on the machine IP, not localhost. I don't understand why that is though.

2017-02-28 15:19 GMT+01:00 W.S. Hager <[hidden email]>:
Well, there's no dashboard.

I'm trying to restore again, but I need to use a different port now. Unfortunately I can't seem to connect to another xmlrpc location (with -ouri param).

2017-02-28 15:13 GMT+01:00 Wolfgang Meier <[hidden email]>:
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
After clearing the expathrepo I have access to xmlrpc again. I'm restoring apps from backup now.

2017-02-28 15:28 GMT+01:00 W.S. Hager <[hidden email]>:
Nor REST, somethings quite wrong I'm afraid.

2017-02-28 15:26 GMT+01:00 W.S. Hager <[hidden email]>:
I can't seem to connect to xmlrpc in other ways, e.g. the java client.

2017-02-28 15:22 GMT+01:00 W.S. Hager <[hidden email]>:
No dice of course: org.apache.xmlrpc.client.XmlRpcHttpTransportException: HTTP server returned unexpected status: Not Found


2017-02-28 15:20 GMT+01:00 W.S. Hager <[hidden email]>:
Ah wait the service runs on the machine IP, not localhost. I don't understand why that is though.

2017-02-28 15:19 GMT+01:00 W.S. Hager <[hidden email]>:
Well, there's no dashboard.

I'm trying to restore again, but I need to use a different port now. Unfortunately I can't seem to connect to another xmlrpc location (with -ouri param).

2017-02-28 15:13 GMT+01:00 Wolfgang Meier <[hidden email]>:
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
It turns out running the repair code will clear all packages. I mean these lines:

import module namespace repair="http://exist-db.org/xquery/repo/repair"
at "resource:org/exist/xquery/modules/expathrepo/repair.xql";
repair:clean-all(),
repair:repair()


2017-02-28 15:42 GMT+01:00 W.S. Hager <[hidden email]>:
After clearing the expathrepo I have access to xmlrpc again. I'm restoring apps from backup now.

2017-02-28 15:28 GMT+01:00 W.S. Hager <[hidden email]>:
Nor REST, somethings quite wrong I'm afraid.

2017-02-28 15:26 GMT+01:00 W.S. Hager <[hidden email]>:
I can't seem to connect to xmlrpc in other ways, e.g. the java client.

2017-02-28 15:22 GMT+01:00 W.S. Hager <[hidden email]>:
No dice of course: org.apache.xmlrpc.client.XmlRpcHttpTransportException: HTTP server returned unexpected status: Not Found


2017-02-28 15:20 GMT+01:00 W.S. Hager <[hidden email]>:
Ah wait the service runs on the machine IP, not localhost. I don't understand why that is though.

2017-02-28 15:19 GMT+01:00 W.S. Hager <[hidden email]>:
Well, there's no dashboard.

I'm trying to restore again, but I need to use a different port now. Unfortunately I can't seem to connect to another xmlrpc location (with -ouri param).

2017-02-28 15:13 GMT+01:00 Wolfgang Meier <[hidden email]>:
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Packages gone after restart in eXist 3.0 latest develop

wshager
Just to be complete: all files in the packages are restored to the db.

2017-02-28 15:44 GMT+01:00 W.S. Hager <[hidden email]>:
It turns out running the repair code will clear all packages. I mean these lines:

import module namespace repair="http://exist-db.org/xquery/repo/repair"
at "resource:org/exist/xquery/modules/expathrepo/repair.xql";
repair:clean-all(),
repair:repair()


2017-02-28 15:42 GMT+01:00 W.S. Hager <[hidden email]>:
After clearing the expathrepo I have access to xmlrpc again. I'm restoring apps from backup now.

2017-02-28 15:28 GMT+01:00 W.S. Hager <[hidden email]>:
Nor REST, somethings quite wrong I'm afraid.

2017-02-28 15:26 GMT+01:00 W.S. Hager <[hidden email]>:
I can't seem to connect to xmlrpc in other ways, e.g. the java client.

2017-02-28 15:22 GMT+01:00 W.S. Hager <[hidden email]>:
No dice of course: org.apache.xmlrpc.client.XmlRpcHttpTransportException: HTTP server returned unexpected status: Not Found


2017-02-28 15:20 GMT+01:00 W.S. Hager <[hidden email]>:
Ah wait the service runs on the machine IP, not localhost. I don't understand why that is though.

2017-02-28 15:19 GMT+01:00 W.S. Hager <[hidden email]>:
Well, there's no dashboard.

I'm trying to restore again, but I need to use a different port now. Unfortunately I can't seem to connect to another xmlrpc location (with -ouri param).

2017-02-28 15:13 GMT+01:00 Wolfgang Meier <[hidden email]>:
As long as expath-pkg.xml and repo.xml are readable and well-formed, it doesn’t matter and the package should show up in the dashboard.

Wolfgang



--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl




--

W.S. Hager
Lagua Web Solutions
http://lagua.nl


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
12
Loading...