collection function

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

collection function

Jehad Najjar
Hello,
 
In my test.xq file, I'm trying to connect to my collection at exist db but no success!
 
I want to query the collection of the xml files at /db/silo! the exist database is located on another server, so I should use the collection("xmldb:exist://servername:8081/db/silo ")  format as mentioned in the exist website, but its not working, has anyone got the correct way of connecting the exist database! or an example!

Regards

--
Najjar


Reply | Threaded
Open this post in threaded view
|

Re: collection function

wolfgangmm
Hi,

> I want to query the collection of the xml files at /db/silo! the exist
> database is located on another server, so I should use the
> collection("xmldb:exist://servername:8081/db/silo ")  format as mentioned in
> the exist website, but its not working, has anyone got the correct way of
> connecting the exist database! or an example!

The query is executed on the server, not the client, so all paths you
specify will be local to the server. It is thus sufficient to use a
relative path: /db/silo.

Wolfgang


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.
Get Certified Today * Register for a JBoss Training Course
Free Certification Exam for All Training Attendees Through End of 2005
Visit http://www.jboss.com/services/certification for more information
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|

Re: collection function

Michael Beddow-2
In reply to this post by Jehad Najjar
>  I want to query the collection of the xml files at /db/silo! the exist
> database is located on another server, so I should use the
> collection("xmldb:exist://servername:8081/db/silo ") format as mentioned
in
> the exist website, but its not working

You don't say exactly how you are transmitting the remote query. But the uri
suggests you are trying to connect to a server running in "standalone" mode.
The documented way of doing this has been wrong for some time now. By
default the "standalone" server offers its three services on port 8088, and
the examples and default client and debug.property settings need altering
accordingly. XMLRPC needs to be addressed to the uri
xmldb:exist://localhost:8088/xmlrpc.

Or you could start the server with bin/server.sh -p8081. But that won't work
for a current CVS build (or, presumably the next snapshot either). There you
set the port for the standalone services in the file server.xml in your
exist root.

Michael Beddow



-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.
Get Certified Today * Register for a JBoss Training Course
Free Certification Exam for All Training Attendees Through End of 2005
Visit http://www.jboss.com/services/certification for more information
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open