eXist-db 3.0 Silent fail on install xar

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

eXist-db 3.0 Silent fail on install xar

Alexander Henket-2
eXist-db 3.0

I tried to install a package with a version dependency on another package, something that the dashboard doesn't surface, but should (request for change no1), but worse: it leads to a silent fail in the latest version of the dashboard. I can find the problem in the exist.log, but that is diving way too deep:

2017-02-20 21:17:27,028 [qtp685131231-37] INFO  (Deploy.java [load]:274) - Retrieving package from http://decor.nictiz.nl/apps/public-repo-dev/modules/find.xql?name=http%3A%2F%2Fart-decor.org%2Fns%2Fterminology-data%2Floinc-data&processor=3.0.4&version=2.58.1 
2017-02-20 21:17:59,789 [qtp685131231-37] ERROR (Deploy.java [installAndDeploy]:194) - Package requires version > 1.9.15 of package http://art-decor.org/ns/terminology. Installed version is 1.9.14. Please upgrade!
org.expath.pkg.repo.PackageException: Package requires version > 1.9.15 of package http://art-decor.org/ns/terminology. Installed version is 1.9.14. Please upgrade!


This used to be visible in the dashboard, so I guess this was broken in eXist-db 3.0/latest dashboard.

Regards

Alexander Henket
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Loading...