Quantcast

minimum system requirements

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

minimum system requirements

Paterson, Duncan
Dear eXist folk,

while testing the 3.0 release *yay* I really like the option to declare min version requirements for my apps. However, I am currently working on one app that will not run on a system configured to the min system specs.  (512mb ram). There is some large SVG and 370k xml records that make up the whole shebang. Testing on an AWS micro instance (1gb system memory/ 512 mb for eXist) this app will reliably error out when installed via packagemanger (old and new) or crash exist when using java admin client.

Is there a way to include checks in the package that will warn and abort if users tries to install on min requirement systems? To be sure the app runs fine with the default 2gb of memory.  

Greetings
Duncan
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Loading...