problem in reindexing subcollection

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

problem in reindexing subcollection

محمد جواد حسنی
dear all,

when i restored my backup, querying the database returned wrong result.

it's not resolved by reindexing the collection but done when i reindex all subcollection manually.

why reindexing nit applied to all subcollection?

my exist-db version is 3.1.
Regards.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem in reindexing subcollection

Dmitriy Shabanov
Hi,

How did you call collection reindex?

On Sat, Mar 18, 2017 at 10:57 AM, محمد جواد حسنی <[hidden email]> wrote:
dear all,

when i restored my backup, querying the database returned wrong result.

it's not resolved by reindexing the collection but done when i reindex all subcollection manually.

why reindexing nit applied to all subcollection?

my exist-db version is 3.1.
Regards.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open




--
Dmitriy Shabanov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem in reindexing subcollection

محمد جواد حسنی
Hi,

i use xmldb:reindex such as below:

xmldb:reindex('/db/data/')



On Sat, Mar 18, 2017 at 11:33 AM Dmitriy Shabanov <[hidden email]> wrote:
Hi,

How did you call collection reindex?

On Sat, Mar 18, 2017 at 10:57 AM, محمد جواد حسنی <[hidden email]> wrote:
dear all,

when i restored my backup, querying the database returned wrong result.

it's not resolved by reindexing the collection but done when i reindex all subcollection manually.

why reindexing nit applied to all subcollection?

my exist-db version is 3.1.
Regards.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open




--
Dmitriy Shabanov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem in reindexing subcollection

Dmitriy Shabanov
On Sat, Mar 18, 2017 at 11:10 AM, محمد جواد حسنی <[hidden email]> wrote:
i use xmldb:reindex such as below:

xmldb:reindex('/db/data/')

It do reindex subcollection too. Do you have dataset to reproduce issue?

--
Dmitriy Shabanov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem in reindexing subcollection

محمد جواد حسنی
No, i have not a dataset.
The data is private and it's belong to our service's users.
The issue happened when i kill the database process. 


On Sat, Mar 18, 2017 at 11:45 AM Dmitriy Shabanov <[hidden email]> wrote:
On Sat, Mar 18, 2017 at 11:10 AM, محمد جواد حسنی <[hidden email]> wrote:
i use xmldb:reindex such as below:

xmldb:reindex('/db/data/')

It do reindex subcollection too. Do you have dataset to reproduce issue?

--
Dmitriy Shabanov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem in reindexing subcollection

Dmitriy Shabanov
On Sat, Mar 18, 2017 at 11:22 AM, محمد جواد حسنی <[hidden email]> wrote:
No, i have not a dataset.
The data is private and it's belong to our service's users.
The issue happened when i kill the database process. 

How did you kill and why you was not able to properly shutdown?


--
Dmitriy Shabanov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem in reindexing subcollection

محمد جواد حسنی
I killed by shell script. I installed a xar package on database(that produced by exist-db 3.0). During the installation, the resources of the host used for long time (about 1 hour )...

On Sat, Mar 18, 2017 at 11:54 AM Dmitriy Shabanov <[hidden email]> wrote:
On Sat, Mar 18, 2017 at 11:22 AM, محمد جواد حسنی <[hidden email]> wrote:
No, i have not a dataset.
The data is private and it's belong to our service's users.
The issue happened when i kill the database process. 

How did you kill and why you was not able to properly shutdown?


--
Dmitriy Shabanov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem in reindexing subcollection

Dmitriy Shabanov
On Sat, Mar 18, 2017 at 11:27 AM, محمد جواد حسنی <[hidden email]> wrote:
I killed by shell script. I installed a xar package on database(that produced by exist-db 3.0). During the installation, the resources of the host used for long time (about 1 hour )...

Next time make threads dump 1st by `kill -3 $pid$`. After check logs for threads dump. Also try to get and save status page. That information will help a lot to debug issue.

--
Dmitriy Shabanov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Exist-open mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/exist-open
Loading...